Want to get rid of the ads? Become a member by registering today.
The Mariah Owners Club

Forum Left Top

Welcome to the The Mariah Owners Club.


Nav Lights not working

Original Mariah Talk

Reply
 
Thread Tools
Old 04-07-2019, 06:17 PM   #1

siudog is currently offline
Posts: 3
Status: Stowaway
Join Date: Nov 2013
My Year: 1993
My Model: MX19
My Engine: 4.3LX
Gallery Images: 0


Thanks: 0
Thanked 0 Times in 0 Posts
Send siudog:
a Private Message
 
Default Nav Lights not working

Ironically, there are recent posts regarding this, and good replies related to switch corrosion, however my 1993 MX19 is showing other weird symptoms. I am good with electrical, so please don't bother with the basics... Neither nav or anchor works, front or back. Front & rear lights works in my other boat. Initially I thought it was the battery even though it is such a small load, because if I put the charger on for a few hours they would work OR while driving, once on plane for awhile and charging up, they would work. Tried 3 other batteries out of my other boats this year and now they don't work at all. Sounds like a switch or ground, but my switch is at the top of the vertical panel of switches and cannot be accessed no matter what. what a hokey design. There is no way I can get at the switch or remove the bank of switches from the dash. any ideas? maybe I'm missing something. I jumpered in a new ground wire no effect. I have the wiring diagram, no juice at the light sockets. Before I rig up a new switch, I thought Id as about switch access, hope you guys can help.
Reply With Quote
  • Old 04-07-2019, 11:36 PM   #2

    mikeyt is currently offline
    Posts: 6,697
    Status: Platinum Contributor
    Join Date: Jul 2007
    Find me on the Map
    Gallery Images: 14


    Thanks: 87
    Thanked 480 Times in 446 Posts
     
    Default Re: Nav Lights not working

    Like it or not, i'm going to remind you of the 'basics'. Check and clean the positive and ground wires at the battery and the connections at the distribution bars. Should be one on the inside of the transom near the battery and another up under the dash. There isn't much else that can go wrong.
    Reply With Quote
    Reply

    Bookmarks




    Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools


    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    Z255 Shabah NAV Lights Not Working SeattleRemedy Original Mariah Talk 2 03-11-2019 09:58 PM
    Courtesy lights not working rosco0000 Introductions 6 10-25-2017 12:28 AM
    nav lights and gauge lights not working lumbercitybravest Original Mariah Talk 5 08-13-2013 05:11 PM
    Navagation lights not working Mariah on the bay Original Mariah Talk 1 06-12-2012 10:13 AM
    Cabin Lights not working Daxgirl Original Mariah Talk 1 04-28-2009 04:07 AM



    Forum Right Top
    Forum Left Bottom Forum Right Bottom
     
    Right Left
    Member Login
    Forgot password?
    Forum LeftForum Right

    About the Club
    Age of the Mariah Owners Club:

    Total Members: 14,625
    Total Threads: 11,557
    Total Posts: 64,192
    Find us on Facebook Follow us on Twitter Subscribe to Mariah Owners Club on YouTube
    There are 63 users
    currently browsing forums.
    Forum LeftForum Right

    Find us on Facebook
    Forum LeftForum Right

    Club Sponsors
    Right Sponsor





    Forum LeftForum Right
    Right Right
    Right Bottom Left Right Bottom Right