Want to get rid of the ads? Become a member by registering today.
The Mariah Owners Club

Forum Left Top

Welcome to the The Mariah Owners Club.


Z308 Pump issue

Original Mariah Talk

Reply
 
Thread Tools
Old 05-24-2009, 05:44 PM   #1

ahughes01 is currently offline
Posts: 35
Status: First Mate
Join Date: May 2009
Location: Seattle
Find me on the Map
My Model: 2001 Mariah Z308
Gallery Images: 3


Thanks: 0
Thanked 0 Times in 0 Posts
Send ahughes01:
a Private Message
 
Red face Z308 Pump issue

I have recently purchased a 2001 Mariah Z308 and dutifully joined our members club... Ahoy fellow owners!

Anyway, as I de-winterized my boat I’ve found an anomaly I’d appreciate the teams guidance on? Whilst in dry-dock as I cleaner the fresh water system of marine de-ice fluid by filling the cold water tank and opening all faucets, I noticed the shower and galley water was not being pumped/discharged overboard. I had ensured the circuit breakers were all closed for ‘Water Pump’, ‘Shower Pump’, and (most importantly) ‘Waste Pump’. When the faucets are open and the water is running I hear the supply & waste pumps quietly running, BUT the tank below the cabin entrance step fills and then overflows into the bilge. What is even more baffling is that I’ve cleaned the tank below the cabin entrance step, and hear the motor in it running, but I do not see water being pumped overboard.

I paid for Mariah Owners Club membership, downloaded and read all the manuals, but I am lost – Any advice or guidance?

I appreciate your time and guidance,
Thanks,
-Adrian
Reply With Quote
  • Old 05-27-2009, 01:07 PM   #2
     
    ShabahZ280's Avatar

    ShabahZ280 is currently offline
    Posts: 3,825
    Status: Admin & Mariah Fanatic
    Join Date: Jun 2007
    Location: Cincinnati, OH
    Find me on the Map
    My Year: 1999
    My Model: Z280 MCC
    My Engine: 7.4L MPI Bravo III
    Gallery Images: 1564


    Thanks: 8
    Thanked 360 Times in 270 Posts
    Send ShabahZ280:
    a Private Message
     
    Default Re: Silly Question Time?

    Did you read the Cruiser water & waste system manual? Hmm, that's an interesting issue, and we'll try and help you through it.
    __________________
    Chris
    -1999 Mariah Z280 MCC, 7.4L MPI Bravo 3 DuoProp
    -2000 Mariah Shabah Z250 Limited Edition, 7.4L MPI, Bravo 1 (Sold, but not forgotten!)
    -Formerly known as ShabahZ250
    -USCG Licensed 50 Ton Near Coastal Master Captain with Towing Certification
    Reply With Quote
    Old 05-27-2009, 07:49 PM   #3

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Smile Re: Z308 Pump issue

    Hi Chris,
    Thanks for your message.

    I have already read 'Mariah Cruiser Water & Waste Systems' guide, and had a print in hand when I looked at it over the weekend.

    In brief summary, waste water from the galley sink and shower tray correctly feed into a sump system tank below the cabin entrance step. The motor in the sump tank appears to be quietly pumping away, but no water is pumped overboard, and after the small sump tank fills it overflows into the forward keel bilge.

    My foolish question is therefore this : Before I strip the system down this coming weekend, are the any obvious things I'm not doing?

    Thanks for all your time guiding this green Mariah owner!
    -Adrian
    Reply With Quote
    Old 05-27-2009, 08:25 PM   #4

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Default Re: Z308 Pump issue

    Oh, and additionally Chris, what's your view on this please?

    My 2001 Z308 with only 42hrs total time apparently spent it's 1st life on Lake Mead AZ, and when I 'test drove' her nearly all instrumentation worked. However, when I took her on the Puget Sound for the first time on Memorial Day several systems failed... 1) the depth sounder would not power on 2) the dash clock stopped working (whatever) 3) the speedometer did not operate anymore 4) she would not restart when I laid anchor so was towed back to harbor (expensive... great! )

    So, it appears my new mistress needs TLC to correct fuel system and system wiring issues. Are there any common threads to these issues? Are Z308 renowned for any of the above faults?

    Thanks yet again for any advice from the Mariah brethren.

    Thanks,
    -Adrian
    Reply With Quote
    Old 05-28-2009, 01:33 AM   #5

    Cliff_Haskins is currently offline
    Posts: 16
    Status: First Lieutenant
    Join Date: Apr 2008
    Gallery Images: 0


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send Cliff_Haskins:
    a Private Message
     
    Default Re: Z308 Pump issue

    This is going to be a completely silly question, I'm sure, but, is your boat equipped with a grey water holding tank?
    Reply With Quote
    Old 05-28-2009, 02:25 PM   #6

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Talking Re: Z308 Pump issue

    Hi Cliff,

    To be honest, I'm not actually sure. My water system has a 25gal fresh water tank, 5gal hot water tank, a tank that toilet waste fluids are held, and a small sump tank under the cabin step to which galley and head sinks enter.

    I haven't any manuals for my Z308 other than those our great owners club site provides, so this coming weekend I'm going to spend time learning more of how my boat systems are actually configured.

    If you have any advice or guidance I greatly appreciate

    Thanks,
    -Adrian
    Reply With Quote
    Old 06-05-2009, 03:44 PM   #7

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Default Re: Z308 Pump issue

    Hi again Cliff.

    It looked like the head/galley sump and its pump have had a long and tiring life, so I've ordered a Johnson replacement (Manuf. Part #: 57151) from West Marine.

    I'll let you know if that solves the drainage issue.

    Thanks again,
    -Adrian
    Reply With Quote
    Old 06-10-2009, 02:06 AM   #8
     
    renaud_gil@yahoo.ca's Avatar

    renaud_gil@yahoo.ca is currently offline
    Posts: 27
    Status: First Lieutenant
    Join Date: Aug 2007
    Location: Sudbury, Ontario, Cana
    Find me on the Map
    Gallery Images: 1


    Thanks: 0
    Thanked 1 Time in 1 Post
    Send renaud_gil@yahoo.ca:
    a Private Message
     
    Default Re: Z308 Pump issue

    Hi Z308 owner,
    We too have purchased one a few years ago, with no manual. I understand your frustration. I still have questions of my own, but first I'll try answer your question. We are pretty sure your water from sink and shower should go into your sewer water tank. I've never tried the shower, but if we ever get warmer than 10 celcius we may try it.
    I wanted to know if you have an inverter. Ours is missing. What is the make & model of yours if you have one. (in the cuddy cabin under the captain's seat.
    Also, do you have those dials 1to9 under the key? Would love to know what they are for.
    Good luck and happy cruising.. Gil
    Reply With Quote
    Old 06-10-2009, 03:31 PM   #9

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Talking Re: Z308 Pump issue

    Good morning Gents!

    Morning Cliff - It's embarrassing to say, but here goes. My '01 Z308 apparently first lived on Lake Mead AZ, so therefore because Lake Mead doubles as a reservoir my 'grey water' is pumped back into the sewer tank to be disposed of appropriately. Thanks for your time Cliff!

    Morning Gil - You were right! As I just explained to Cliff, my head & galley collection sump indeed pumps into the sewer water tank. My main problem was my sump unit, which after replacement from West Marine now works perfectly (http://www.westmarine.com)(Johnson Pumps, Multiple Port Shower Sump, Manu.Part #: 57151, $120).

    Regarding your questions Gil :
    >>I wanted to know if you have an inverter. Ours is missing. What is the make
    >>& model of yours if you have one. (in the cuddy cabin under the captain's seat.
    Yes I do have a power inverter installed. I just had to replace my isolator switch so was rummaging around that neck of the woods, and whilst I cannot recall the name and part number I'll try to snoop around when my I'm next onboard.

    >>Also, do you have those dials 1to9 under the key? Would love to know
    >>what they are for.
    Yes, I had the same conundrum myself! …hahaha!! It is an keyless ignition system which our said Mariah Owners Club manual archive has some documentation for (http://www.mariahownersclub.com/foru...read.php?t=667). Personally I use the ignition START/STOP buttons to operate the engine now, and I am impressed not having to fumble around with keys on a 2001 age craft.

    I'll look up the power inverter details as soon as possible.

    Happy cruising!
    -Adrian
    Reply With Quote
    Old 06-28-2009, 11:59 PM   #10

    ahughes01 is currently offline
    Posts: 35
    Status: First Mate
    Join Date: May 2009
    Location: Seattle
    Find me on the Map
    My Model: 2001 Mariah Z308
    Gallery Images: 3


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send ahughes01:
    a Private Message
     
    Default Re: Z308 Pump issue

    Hi Gil,

    I finally got my touché in gear and dug around the engine bay for you this Saturday as I replaced solenoids on my Bennett trim tabs.

    The central power controller on my boat (battery isolator switch) is a ‘New-Mar’ unit model number 1-3-120.

    When I spoke with the marine repair shop last week as they serviced my boat, they told me mine needed replacing as it was not channeling AC land power or alternator power to two of my DC batteries, hence my starting issues. From my understanding this may therefore be the inverter you’re asking about, but if I’m talking gibberish please say and I’ll look into it further.

    Please let me know if thius helps you or if I can help in any way?

    Tailwinds,
    -Adrian
    Reply With Quote
    Reply

    Bookmarks




    Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools


    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    Bilge pump issue adornare Original Mariah Talk 12 03-29-2010 04:30 AM
    Camper top for 2001 Z308 clintonbush1 Original Mariah Talk 2 08-15-2008 06:32 PM
    Parts for Z308 searching topgunwolf Original Mariah Talk 13 05-30-2008 12:50 AM
    Z308 renaud_gil@yahoo.ca Introductions 2 04-15-2008 12:57 AM
    Z308 Parts - Dimensions topgunwolf Original Mariah Talk 10 04-15-2008 12:20 AM



    Forum Right Top
    Forum Left Bottom Forum Right Bottom
     
    Right Left
    Member Login
    Forgot password?
    Forum LeftForum Right

    About the Club
    Age of the Mariah Owners Club:

    Total Members: 16,442
    Total Threads: 12,516
    Total Posts: 66,631
    Find us on Facebook Follow us on Twitter Subscribe to Mariah Owners Club on YouTube
    There are 125 users
    currently browsing forums.
    Forum LeftForum Right

    Find us on Facebook
    Forum LeftForum Right

    Club Sponsors
    Right Sponsor





    Forum LeftForum Right
    Right Right
    Right Bottom Left Right Bottom Right