Want to get rid of the ads? Become a member by registering today.
The Mariah Owners Club

Forum Left Top

Welcome to the The Mariah Owners Club.


Missfire

Mercury MerCruiser

Reply
 
Thread Tools
Old 06-17-2021, 12:05 AM   #1

A_Light48 is currently offline
Posts: 1
Status: Stowaway
Join Date: Jun 2021
My Year: 1990
My Model: 1850XL
My Engine: 4.3L Alpha One
Gallery Images: 0


Thanks: 0
Thanked 0 Times in 0 Posts
Send A_Light48:
a Private Message
 
Default Missfire

I replaced the carburetor on my 4.3 mercruiser this winter. It developed a missfire around 4300 rpms. I have replaced the cap, rotor, ignition coil, plugs and wires. But itís still missing. Starts great and runs amazing at all rpms other then that ones spot, any ideas? Thanks
Reply With Quote
  • Old 06-17-2021, 03:07 AM   #2

    mikeyt is currently offline
    Posts: 7,329
    Status: Platinum Contributor
    Join Date: Jul 2007
    Location: Ontario
    Find me on the Map
    Gallery Images: 14


    Thanks: 87
    Thanked 564 Times in 524 Posts
     
    Default Re: Missfire

    Probably the first thing i would check / replace is the wire from the tach to the coil. Next step would be to double check your timing. It may need to be retarded just a bit.
    Reply With Quote
    Reply

    Bookmarks




    Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools




    Forum Right Top
    Forum Left Bottom Forum Right Bottom
     
    Right Left
    Member Login
    Forgot password?
    Forum LeftForum Right

    About the Club
    Age of the Mariah Owners Club:

    Total Members: 17,290
    Total Threads: 12,561
    Total Posts: 67,267
    Find us on Facebook Follow us on Twitter Subscribe to Mariah Owners Club on YouTube
    There are 148 users
    currently browsing forums.
    Forum LeftForum Right

    Find us on Facebook
    Forum LeftForum Right

    Club Sponsors
    Right Sponsor





    Forum LeftForum Right
    Right Right
    Right Bottom Left Right Bottom Right