Want to get rid of the ads? Become a member by registering today.
The Mariah Owners Club

Forum Left Top

Welcome to the The Mariah Owners Club.


Radio Amplifier 1997 Mariah Jubilee 214

General Maintenance

Reply
 
Thread Tools
Old 10-08-2020, 11:37 PM   #1

sklein13 is currently offline
Posts: 3
Status: Silver Contributor
Join Date: Oct 2020
My Year: 1997
My Model: Jubilee 214
My Engine: 5.7L Bravo 3
Gallery Images: 0


Thanks: 0
Thanked 0 Times in 0 Posts
Send sklein13:
a Private Message
 
Default Radio Amplifier 1997 Mariah Jubilee 214

Help!

I just bought a 1997 Jubilee 214 and replaced the radio. I have power to the radio and to the speakers, but cannot get any sound. I checked the fuses on the back of the new radio and on the harnesses and they are good. Is there an amplifier somewhere that might have a fuse in it? The horn is not working either so I didn't know if they were somehow connected by a shared fuse? I am at my wits end.

Shane Klein
Reply With Quote
  • Old 10-09-2020, 02:28 AM   #2

    mikeyt is currently offline
    Posts: 7,236
    Status: Platinum Contributor
    Join Date: Jul 2007
    Location: Ontario
    Find me on the Map
    Gallery Images: 14


    Thanks: 87
    Thanked 554 Times in 514 Posts
    Send mikeyt:
    a Private Message
     
    Default Re: Radio Amplifier 1997 Mariah Jubilee 214

    The horn is on the same circuit as the stereo and accessory plug but there is no amplifier that I'm aware of unless a prior owner installed one. Wires going to the radio should all of been labelled.
    Reply With Quote
    Old 10-09-2020, 02:34 AM   #3

    sklein13 is currently offline
    Posts: 3
    Status: Silver Contributor
    Join Date: Oct 2020
    My Year: 1997
    My Model: Jubilee 214
    My Engine: 5.7L Bravo 3
    Gallery Images: 0


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send sklein13:
    a Private Message
     
    Default Re: Radio Amplifier 1997 Mariah Jubilee 214

    Thank you! I will pull the circuit board tomorrow and take the fuse block marked horn out and replace it. I assume that the individual fuse block has a blade type fuse in it,.
    Reply With Quote
    Old 10-19-2020, 12:38 AM   #4

    sklein13 is currently offline
    Posts: 3
    Status: Silver Contributor
    Join Date: Oct 2020
    My Year: 1997
    My Model: Jubilee 214
    My Engine: 5.7L Bravo 3
    Gallery Images: 0


    Thanks: 0
    Thanked 0 Times in 0 Posts
    Send sklein13:
    a Private Message
     
    Default Re: Radio Amplifier 1997 Mariah Jubilee 214

    Update- I replaced the 5A crcuit breaker and still nothing. The horn doesn't work at all, but it may need to be replaced. Scratching my head over this radio.
    Reply With Quote
    Old 10-19-2020, 03:16 PM   #5

    mikeyt is currently offline
    Posts: 7,236
    Status: Platinum Contributor
    Join Date: Jul 2007
    Location: Ontario
    Find me on the Map
    Gallery Images: 14


    Thanks: 87
    Thanked 554 Times in 514 Posts
    Send mikeyt:
    a Private Message
     
    Default Re: Radio Amplifier 1997 Mariah Jubilee 214

    Do the simple things first. Find a speaker and attach it directly to one of the speaker wires coming out of the rear of the deck. If it works then there is a problem in the speaker wires. If it doesn't then it's likely a problem with the new radio.

    Check the fuse in the back of the radio. Mine has a 10amp.

    Make sure all of your power/ground wires are hooked up to the correct source: Red to terminal controlled by the ignition, yellow to constant power, blue/white to the antenna booster and black to ground. I'm not sure what stereo you have so you may have to check these against what your manual states.

    Ensure that all of your connections (including your grounds) are solid & secure. Make sure there is no bare wires that might short out the system.

    Make sure you have continuity in the wires to all speakers and use a volt meter to read the voltage at each.

    Re-check the settings on your radio. Make sure you haven't accidently muted the radio thru the settings.

    There are plenty of self-help guides regarding stereo troubleshooting on the internet and its usually something simple that is causing a problem. You just need to take things one step at a time..

    Last edited by mikeyt; 10-19-2020 at 03:25 PM.
    Reply With Quote
    Reply

    Bookmarks




    Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools


    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    1997 mariah jubilee 244 Rwallaker Mercury MerCruiser 0 12-11-2019 07:05 PM
    Member Boat For Sale: 1997 Jubilee 214 Miked5207 Mariah Boats For Sale & Wanted 4 06-17-2017 10:11 PM
    Looking to Buy a 1997 Mariah Jubilee z244 naomi0713 Original Mariah Talk 2 12-19-2012 11:59 PM
    Stereo Amplifier Locations jasfiveo Original Mariah Talk 2 01-05-2010 10:40 PM
    1997 Jubilee ATI WS6 Original Mariah Talk 7 07-27-2009 11:57 PM



    Forum Right Top
    Forum Left Bottom Forum Right Bottom
     
    Right Left
    Member Login
    Forgot password?
    Forum LeftForum Right

    About the Club
    Age of the Mariah Owners Club:

    Total Members: 16,944
    Total Threads: 13,005
    Total Posts: 67,450
    Find us on Facebook Follow us on Twitter Subscribe to Mariah Owners Club on YouTube
    There are 102 users
    currently browsing forums.
    Forum LeftForum Right

    Find us on Facebook
    Forum LeftForum Right

    Club Sponsors
    Right Sponsor





    Forum LeftForum Right
    Right Right
    Right Bottom Left Right Bottom Right